Hur man räknar tecken i Microsoft Excel

0
61

Till skillnad från Word där du enkelt kan få dokumentets teckenantal med hjälp av ett verktyg i menyraden måste du använda LEN-funktionen om du vill få ett teckenantal i Excel. Så här använder du det.

Innehållsförteckning

Hur får du teckenräkningen för en enskild cell
Hur får man teckenräkningen för flera celler
Hur får man räkningen av en specifik karaktär i en cell

Hur man får teckenräkningen för en enskild cell

Du kan använda LEN-funktionen för att snabbt räkna antalet tecken i en enskild cell på två olika sätt.

Att använda LEN funktionen för att få teckenantalet, klicka på cellen du vill placera teckenantalet i. Efter det skriver du =LEN(cell) , där cell är den faktiska cellen du vill få teckenantalet för. Så om du vill få teckenantalet för cell A1, anger du:

=LEN(A1)

Klicka på en annan cell så visas teckenantalet.

Eller så kan du helt enkelt kopiera innehållet i cellen du vill ha för att få tecknet count of, klistra in det i formeln i stället för referenscellen och linda in det inom citattecken. Till exempel:

=LEN(“Hur många tecken finns i den här cellen?”)

< /p>

Detta ger samma resultat.

Annons

Om du analyserar data kanske du också vill dela upp din text i flera kolumner.

Hur man får teckenräkningen för flera celler

LÄN-funktionen kan också användas i kombination med SUM-funktionen för att få teckenantalet för flera celler. Klicka först på den cell du vill placera ordantalet i. Ange sedan formeln:

=SUMMA(LEN(A1),LEN(A2))

Ersätt cellnumren med dina egna.

Klicka på valfri annan cell och antalet tecken kommer att returneras.

Du kan lägga till så många celler du vill i formeln.

Det är också lätt att kombinera text från dessa olika celler till en.

RELATERAT: Hur man kombinerar text från flera celler till en cell i Excel

Hur man får räkningen av en specifik karaktär i en cell

Du kan också använda LEN-funktionen för att få räkningen av hur många gånger ett specifikt tecken förekommer i en cell. Välj cellen du vill att antalet ska returneras i och ange sedan denna formel:

=LEN(A1)-LEN(SUBSTITUTE(A1,”a”,””)) Annons
< p>Byt ut cellen ( A1 ) med din referenscell och en med det tecken du vill få räkningen av. I vårt fall söker vi efter hur många gånger a förekommer i cell A1.

Klicka på en annan cell så returneras antalet av det angivna tecknet.

Det är allt som behövs. Excel är fullt av extremt användbara funktioner, från COUNTIF-funktionen till FREQUENCY-funktionen till många olika logiska funktioner, alla designade för att effektivisera ditt arbetsflöde.

RELATERAT: Användbara funktioner Du bör lära känna

LÄS NÄSTA

  • › 5 webbplatser varje Linux-användare bör bokmärka
  • › Datormappen är 40: Hur Xerox Star skapade skrivbordet
  • › Cyber ​​Monday 2021: Bästa Apple-erbjudanden
  • › Cyber ​​Monday 2021: Bästa tekniska erbjudanden
  • › Hur du hittar din Spotify Wrapped 2021
  • › Cyber ​​Monday 2021: Bästa PC-erbjudanden