Hur att Räkna Tomma eller Tomma Celler i Google Kalkylark

0
42

När du analyserar data i ett kalkylblad, räkna tom eller tomma celler kan hjälpa dig att fokusera på specifika områden. Detta är anledningen till att funktioner som COUNTBLANK, ANTAL.OM, COUNTIFS, och PRODUKTSUMMA är så viktigt i Google Kalkylark.

Ett ord av varning dock. Om du har en cell som innehåller en tom text-sträng (“”) eller har en formel som returnerar ett liknande resultat, denna cell skulle vara tom, men skulle det tekniskt inte vara tomt. Om du vill veta antalet verkligt tomma celler, måste du använda en kombination av SUMMAN, RADER, KOLUMNER och ANTAL.OM funktioner.

Med hjälp av COUNTBLANK

Du kan prova COUNTBLANK funktion för att räkna antalet tomma celler i ett Google-Kalkylark kalkylblad. Detta är det snabbaste sättet att hitta antalet tomma, men inte tomma celler.

Celler som innehåller tal eller text kommer inte räknas, inklusive celler med siffran noll. Som vi har nämnt, men om en cell ser tomt, men den innehåller en tom text-sträng (“”), kommer detta att räknas.

Att använda det för att öppna ditt Google-Lakan kalkylblad. Klicka på en tom cell och skriv =COUNTBLANK(intervall). Byt sortiment med din mobil sortiment.

Till exempel, om du ville räkna antalet tomma celler mellan kolumnerna A och C, skulle du typ =COUNTBLANK(EN:C).

I exemplet ovan, celler från A3 till H24 används inom området. Detta sortiment innehåller fyra tomma celler (B4, C4, D4 och E4), vilket är samma siffra COUNTBLANK rapporter i cell A1.

Med hjälp av ANTAL.OM och COUNTIFS

Medan COUNTBLANK returnerar antalet tomma celler, kan du också använda ANTAL.OM eller COUNTIFS för att uppnå samma resultat.

ANTAL.OM räknar antalet celler som uppfyller de kriterier du definierar i själva formeln. Eftersom du vill räkna tomma celler kan du använda en tom textsträng som dina kriterier.

Att använda ANTAL.OM, öppna ditt Google-Lakan kalkylblad och klicka på en tom cell. Typ =ANTAL.OM(sortiment,””), som ersätter sortiment med din valda cellområdet.

Exemplet ovan har tre tomma celler (B4, C4 och D4) inom intervallet A3 till H24, med ANTAL.OM-funktion i cell A1 återvänder samma antal tomma celler.

Den COUNTIFS funktionen kan användas som ett alternativ till ANTAL.OM. Användningen =COUNTIFS(sortiment,””), som ersätter sortiment med dina markerade cellområdet.

I exemplet ovan, fyra tomma celler i A3 till H24 cellområdet hittades.

Med hjälp PRODUKTSUMMA

Den funktionen PRODUKTSUMMA erbjuder en något mer komplicerad rutt för att räkna antalet tomma celler. Det räknar antalet celler som matchar vissa kriterier som, i detta fall, skulle vara ett tomt sms: a sträng (“”).

Att använda PRODUKTSUMMA, öppna ditt Google-Lakan kalkylblad och klicka på en tom cell. Typ =PRODUKTSUMMA(–(range=””)), ersätter sortiment med din valda cellområdet.

Exemplet ovan visar att i A2 för att H24 cell rad, två tomma celler (B4 och C4) hittades.

Räkna Tomma Celler

Alla funktioner som anges ovan räkna celler som är tomma, men som inte är tekniskt tom. Om en funktion som returnerar ett null-eller tomt resultat, eller om du har en tom text-sträng (“”) i en cell, sedan de celler som räknas som tomt.

En lösning på detta problem är att använda ANTAL.OM för att räkna antalet celler med ett värde, så för att använda en andra ANTAL.OM formel för att räkna antalet celler som innehåller text eller tomma textsträngar.

Du kan sedan lägga till resultaten från dessa beräkningar och dra dem från att antalet celler i dina uppgifter utbud. Du kommer att behöva veta hur många av cellerna i området först. För att ta reda på det, som du kan använda för RADER och KOLUMNER funktioner.

För att starta, öppna ditt Google-Lakan kalkylbladet, klicka på en tom cell och skriv =RADERNA(rad)*KOLUMNER(område), som ersätter range-värdet med din mobil sortiment.

I en andra tom cell, typ =ANTAL.OM(rad,”>=0″) för att räkna antalet celler med ett numeriskt värde. Återigen, byta rad med lämplig cell sortiment för dina data.

För att söka efter tomma celler eller celler som innehåller text, typ =ANTAL.OM(rad,”*”) i en tredje tom cell. Byt utbud som krävs.

Du kan sedan använda SUMMAN för att lägga upp dina två ANTAL.OM värden, subtrahera att räkna antalet celler i ditt område beräknas med hjälp av RADER och KOLUMNER funktioner.

I vårt exempel, det totala antalet celler kan hittas i cell B8, antalet celler med ett numeriskt värde i B9, och antalet celler som innehåller text eller en tom textsträng i B10.

Att ersätta dessa värden cellen med din egen, kan du använda =B8-SUMMAN(B9:10) för att bestämma antalet verkligt tomma celler i ditt område.

Som exemplet ovan visar, i ett urval av 20 celler (A2 till E5), 19 celler har befunnits ha antingen ett nummer, sms: a, eller tom textsträng. Endast en cell, E4, var helt tom.

LÄS NÄSTA

  • “Hur säkerhetskopierar Din Kindle Höjdpunkter och Anteckningar
  • “12 Familj Teknisk Support Tips för Semester
  • “Thunderbolt 3 vs. USB-C: Vad är Skillnaden?
  • “Hur att Dela en Levande Bild som en GIF till Twitter från Din iPhone eller iPad
  • “Som iphone Har Stående Läge?