Hur man Använder och-OCH ELLER-Funktioner i Google Kalkylark

0
68

Om du någonsin ville kontrollera om data från ditt Google-Lakan kalkylblad uppfyller vissa kriterier, kan du använda OCH och ELLER. Dessa logiska funktioner ger dig SANNA och FALSKA svar, som du kan använda för att sortera dina data.

Om du använder OCH med flera argument, alla dessa argument måste vara sant för att få ett korrekt svar, annars, OCH svarar FALSKT. Om du använder ELLER, som ett enda argument har för att vara sant för ELLER att ge ett korrekt svar.

Du kan använda OCH och ELLER separat eller inom andra funktioner, som OM.

Hjälp OCH Funktion

Du kan använda OCH fungera i sin egen eller i kombination med andra funktioner för att ge en logisk (SANT eller FALSKT) test.

För att komma igång, öppna ett Google-Kalkylark kalkylblad och klicka på en tom cell. Typ =OCH(Argument, Argument B), och ersätt varje argument med de kriterier som du vill använda. Du kan använda så många argument som du vill, men du måste ha minst en för OCH att arbeta.

I exemplet nedan har vi använt tre argument. Det första argumentet är den enkla beräkningen av 1+1=2.

Andra hävdar att en cell E3 är lika med antalet 17.

Slutligen, den tredje hävdar att värdet i cell F3 (3) är lika med beräkningen 4-1.

Som alla tre argumenten är sanna, OCH formel svarar SANT i cell A2. Om vi ändrar något av dessa argument, kommer det att orsaka OCH formel i A2 för att ändra svar från SANT till FALSKT.

I exemplet nedan, OCH en formel i cellen A3 har två rätt argument och en som är felaktiga (F3=10, medan F3 faktiskt motsvarar 3). Detta orsakar OCH att svara med FALSKA.

Med ELLER Funktion

Tag OCH kräver att alla de argument som man använder för att vara sant, ELLER funktionen endast krävs en för att vara sant för ELLER att besvara med SANT.

Ut, OCH du kan använda ELLER en funktion på sin egen eller kombinera det med andra funktioner. Samma som med, OCH du kan använda så många argument som du vill, men du måste ha minst en för att det ska fungera.

Att använda ELLER klicka på en tom cell och skriv =ELLER(Argument, Argument B), och ersätta argument med din egen.

I exemplet nedan är den formel som använder ELLER i cell A2 har ett felaktigt argument av tre (F3=10, där F3 faktiskt motsvarar 3).

Till skillnad från när du använder OCH felaktiga argument av tre kommer att resultera i en VERKLIG resultat. För en FALSK grund, alla de argument du använder måste vara fel.

I exemplet nedan, ELLER formler i cellerna A4 och A5 som returneras FALSKT, eftersom alla tre argument i båda formlerna är felaktiga.

Med hjälp av and OCH or med OM

Eftersom och-OCH ELLER-är logiska funktioner med SANNA och FALSKA svar, kan du också använda dem med OM. När du använder OM, om ett argument är SANT, den returnerar ett värde, annars returneras ett annat värde.

Formatet av en formel med OM är =OM(Argument, Värde OM uttrycket är SANT, Värde OM det är FALSKT). Till exempel som visas nedan, =OM(E2=1,3,4) gör OM för att returnera antalet 3 om cell E2 är lika med 1, annars returneras nummer 4.

För OM bara stöder ett enda argument, som du kan använda och-OCH ELLER-att införa komplexa logiska tester med flera argument.

Hjälp OCH med OM

Att använda OCH inom en OM-formel skriver du =OM(OCH(OCH Argument 1), Värdet OM SANT Värde OM det är FALSKT), och ersätta din OCH argument (eller argument), och OM det är SANT och OM det är FALSKT-värden.

I vårt exempel nedan, använde vi OM med en kapslad OCH formel i cell A2 med fyra argument. Alla fyra argument är rätt, så OM det SANNA värdet (i detta fall, “Ja”) är tillbaka.

I cell A3, en liknande OM med OCH formel innehåller två felaktiga argument. Så OCH kräver att alla argument för att vara korrekt, OM returnerar OM FALSKT värde, vilket är en annan textsträng (“Nej”).

Hjälp ELLER OM

Samma som med, OCH du kan också använda ELLER med OM att skapa en komplex logiskt test. Endast en ELLER argument måste vara rätt för OM att returnera ett SANT svar.

Att använda ELLER med OM, klicka på en tom cell och skriv =OM(ELLER(ELLER Argument 1), Värdet OM SANT Värde OM det är FALSKT).

Ersätta ELLER argument (eller argument), och din OM SANT/FALSKT-värden, som krävs.

I vårt exempel nedan, de två OM med ELLER formler i cellerna A2 och A3 returneras OM uttrycket är SANT, sms: a värde (“Ja”). Alla fyra argument är korrekta i A2 OM med ELLER formel, medan A3 har två felaktiga argument av fyra.

I cell A4, alla fyra argument i OM med ELLER formel är felaktiga. Det är därför generellt OM formeln returnerar OM FALSKA sms: a värde (“Nej”), i stället.

LÄS NÄSTA

  • “Hur du Använder Din Kalender Från Windows 10 Aktivitetsfältet
  • “Vad Gör jag minns Menar, och Hur Använder Man Det?
  • “Vad Är Wiki och Hur Använder Man Det?
  • “Hur kan man Använda Kommandot dmesg på Linux
  • “Kan Min iPhone eller iPad för att Få ett Virus?