Hoe te Gebruiken het en-EN OF-Functies in Google spreadsheets

0
141

Als je ooit wilde om te controleren of de gegevens van uw Google Bladen werkblad voldoet aan bepaalde criteria voldoen, kun je gebruik maken van EN en OF. Deze logische functies geven u juiste en onjuiste antwoorden, die u kunt gebruiken om te sorteren door middel van uw gegevens.

Als u met meerdere argumenten, al die argumenten moet worden voldaan om een echt antwoord; anders EN reageert met VALS. Als u OF gebruikt, slechts één argument is om waar te zijn OF om te zorgen voor een ECHTE reactie.

U kunt gebruik maken van en-EN OF-afzonderlijk of in andere functies, zoals ALS.

Met behulp van de Functie

U kunt gebruik maken van de functie op zichzelf of in combinatie met andere functies om een logische (TRUE of FALSE) test.

Aan de slag, het openen van een Google Bladen werkblad en klik op een lege cel. Type =EN(Een Argument, Argument B) en vervang elk argument met de criteria die u wilt gebruiken. U kunt zo veel argumenten aan als u wilt, maar u moet op zijn minst één voor EN te werken.

In het voorbeeld hieronder gebruiken we drie argumenten. Het eerste argument is de eenvoudige berekening van u 1+1=2.

De tweede stelt dat de cel E3 is gelijk aan het getal 17.

Tot slot, de derde betoogt dat de waarde van cel F3 (3) is gelijk aan de berekening van 4-1.

Als alle drie de argumenten waar zijn, EN de formule reageert met WARE in cel A2. Als we veranderen elk van deze argumenten, het zorgt ervoor dat de formule in A2 wijzigen van de reactie van TRUE naar FALSE.

In het voorbeeld hieronder, EN de formule in cel A3 heeft twee juiste argumenten en dat is onjuist (F3=10, terwijl F3 eigenlijk is gelijk aan 3). Deze oorzaken EN te reageren met VALS.

Met behulp van de OF-Functie

Tijdens EN vereist dat alle argumenten gebruikt om waar te zijn, OF de functie vereist alleen een voor waar worden OF om te reageren met TRUE.

Wilt EN kunt u gebruik maken van de OF-functie op zijn eigen of het combineren met andere functies. Hetzelfde als met EN u kunt zo veel argumenten in als je wilt, maar je moet op zijn minst één voor het werk.

Te gebruiken in OF klik op een lege cel en typ =OF(Een Argument, Argument B) en vervang de argumenten met uw eigen.

In het onderstaande voorbeeld is de formule met OF in cel A2 is een onjuist argument van de drie (F3=10, waar F3 eigenlijk is gelijk aan 3).

In tegenstelling tot wanneer u, een onjuist argument van de drie zal resulteren in een resultaat TRUE. Voor een VALS resultaat, alle argumenten die je gebruikt moet worden, onjuist is.

In het voorbeeld hieronder, de formules in de cellen A4 en A5 terug van een VALSE reactie, want alle drie de argumenten van beide formules zijn onjuist.

Het gebruik van en-EN OF-met ALS

Omdat EN en OF zijn logische functies met goede en foute antwoorden, u kunt ze ook gebruiken met ALS. Wanneer u, ALS een argument WAAR is, is het resultaat een waarde heeft; anders is het resultaat een andere waarde.

De indeling van een formule met ALS =ALS(Argument Waarde ALS TRUE, Waarde ALS FALSE). Bijvoorbeeld, zoals hieronder weergegeven, =ALS(E2=1,3,4) veroorzaakt ALS om terug te keren de nummer 3 als cel E2 gelijk is aan 1; anders is het resultaat van de nummer 4.

Want ALS ondersteunt slechts een enkel argument, dat u kunt gebruiken EN OF de invoering van complexe logische tests met meerdere argumenten.

Met behulp van EN met ALS

Te gebruiken EN binnen een ALS formule, typt u =ALS(EN(EN Argument 1), de Waarde ALS TRUE, Waarde ALS FALSE), en vervang je EN argument (of argumenten), en ALS het WAAR is en ALS FALSE-waarden.

In ons voorbeeld hieronder gebruiken we ALS met een geneste formule in cel A2 met vier argumenten. Alle vier argumenten zijn correct, dus ALS de WERKELIJKE waarde (in dit geval “Ja”) geretourneerd.

In cel A3, een soortgelijke ALS met EN formule bevat twee onjuiste argumenten. Zo, EN moeten alle argumenten om juist te zijn, ALS resultaat ALS de waarde FALSE, die een verschillende tekst-waarde (“Nee”).

Met behulp van OF met ALS

Hetzelfde als met EN kunt u ook gebruik maken van OF met ALS te maken van een complexe logische test. Slechts één OF argument heeft om correct te zijn voor ALS de terugkeer van een ECHTE reactie.

Om te gebruiken OF ALS het op een lege cel en typ =ALS(OF(OF (Argument 1), de Waarde ALS TRUE, Waarde ALS FALSE).

Vervang het OF argument (of argumenten), en je ALS TRUE/FALSE-waarden, zoals vereist.

In onze voorbeelden hieronder zijn de twee ALS met OF formules in cellen A2 en A3 geretourneerd ALS de tekst WAAR waarde (“Ja”). Alle vier argumenten correct zijn in de A2 ALS met OF formule, terwijl A3 heeft twee onjuiste argumenten van de vier.

In cel A4, alle vier argumenten in de ALS met OF formule onjuist zijn. Dit is de reden waarom de algemene ALS de formule geeft als resultaat ALS de waarde FALSE tekst (“Nee”), in plaats van.

LEES VERDER

  • “Hoe Gebruik je Je Agenda Van Windows 10 Taakbalk
  • “Wat Doet IIRC Betekenen en Hoe Gebruik Je Het?
  • “Wat Is Markdown en Hoe Gebruik Je Het?
  • “Het Gebruik van het dmesg Commando op een Linux
  • “Kan Mijn iPhone of iPad een Virus?