Wie Finden die Daten in Google-Tabellen mit SVERWEIS

0
44

SVERWEIS ist eine der am meisten missverstandenen Funktionen in Google Tabellen. Es ermöglicht Ihnen, zu durchsuchen und miteinander verknüpfen zwei Sätze von Daten in Ihrer Tabelle mit einem einzigen Wert haben. Hier ist, wie es zu benutzen.

Im Gegensatz zu Microsoft Excel, gibt es keine SVERWEIS-Assistenten, mit dem Sie in Google Sheets, so dass Sie geben Sie die Formel manuell.

Wie der SVERWEIS Funktioniert in Google Sheets

SVERWEIS klingt verwirrend, aber es ist ziemlich einfach, wenn Sie verstehen, wie es funktioniert. Eine Formel, die verwendet die Funktion SVERWEIS hat vier Argumente.

Die erste ist die Suche-Taste Wert, den Sie suchen, und der zweite ist der Zellbereich, die Sie suchen (z.B. A1 bis D10). Das Dritte argument ist die Spalte index-Nummer aus Ihrem Bereich gesucht werden, wo die erste Spalte, die in Ihrem Bereich die Nummer 1, das nächste die Nummer 2 und so weiter.

Das vierte argument ist, ob die Suche nach der Spalte sortiert wurde oder nicht.

Das Letzte argument ist nur dann wichtig, wenn Sie sich für das nächste match zu Ihrer Suche nach Schlüssel-Wert. Wenn Sie sich lieber zurück exakten übereinstimmungen für Ihre Suche nach Schlüssel, die Sie dieses argument auf FALSE festlegen.

Hier ist ein Beispiel, wie Sie vielleicht verwenden Sie SVERWEIS. Ein Unternehmen, Tabellenkalkulation könnten zwei Blätter: das eine mit einer Liste der Produkte (jeweils mit einer ID-Nummer und Preis), und eine zweite mit einer Liste von Aufträgen.

Sie können die ID-Nummer als Ihre SVERWEIS Suchwert zu finden, der Preis für jedes Produkt schnell.

Eine Sache zu beachten ist SVERWEIS können nicht durchsuchen Sie Daten auf der linken Seite der Spalte index-Nummer. In den meisten Fällen müssen Sie entweder ignorieren Sie die Daten in Spalten auf der linken Seite der search-Taste oder legen Sie Ihre Suche nach Schlüssel Daten in der ersten Spalte.

Mit SVERWEIS auf ein Einzelnes Blatt

Für dieses Beispiel, sagen wir, Sie haben zwei Tabellen mit Daten auf einem einzelnen Blatt. Die erste Tabelle ist eine Liste der Mitarbeiter, Namen, ID-Nummern und Geburtstage.

In einer zweiten Tabelle, die Sie verwenden können, SVERWEIS zum suchen nach Daten, die verwendet eines der Kriterien aus der ersten Tabelle (name, ID-Nummer, oder zum Geburtstag). In diesem Beispiel benutzen wir SVERWEIS zu bieten, den Geburtstag für einen bestimmten Mitarbeiter-ID-Nummer.

Die entsprechende SVERWEIS-Formel HIERFÜR lautet =SVERWEIS(F4, A3:D9, 4, FALSE).

Brechen diese nach unten, SVERWEIS verwendet die F4-Zelle mit dem Wert (123) wie die Suche nach Schlüssel und sucht im Zellbereich von A3 bis D9. Es gibt Daten aus der Spalte mit der Nummer 4 in diesem Bereich (Spalte D, “Geburtstag”), und, da wir eine genaue übereinstimmung wünschen, das Letzte argument ist FALSCH.

In diesem Fall für die ID-Nummer 123, SVERWEIS gibt ein Geburtsdatum von 19/12/1971 (mit der DD/MM/YY-format). Wir erweitern das Beispiel noch weiter durch das hinzufügen einer Spalte in Tabelle B für die Familiennamen, so dass es link ist der Geburtstag Termine für wirkliche Menschen.

Dies erfordert nur eine einfache änderung an der Formel. In unserem Beispiel in Zelle H4 =SVERWEIS(F4, A3:D9, 3, FALSE)sucht nach dem Nachnamen, dass die Spiele ID Nummer 123.

Anstatt den Geburtstag, es gibt die Daten aus der Spalte mit der Nummer 3 (“Nachname”) abgestimmt, um den ID-Wert in Spalte Nummer 1 (“ID”).

Verwenden Sie SVERWEIS mit Mehreren Blättern

Das obige Beispiel verwendet eine Reihe von Daten aus einem einzigen Blatt, aber Sie können auch verwenden Sie SVERWEIS zu suchen, die Daten über mehrere Blätter in einer Tabelle. In diesem Beispiel werden die Informationen aus Tabelle A ist jetzt auf einem Blatt namens “Mitarbeiter”, während die Tabelle B wird nun auf einem Blatt namens “Geburtstage.”

Anstelle der Verwendung einer typischen Zelle-Palette wie z.B. A3:D9, Sie können klicken Sie auf eine leere Zelle, und geben Sie dann ein: =SVERWEIS(A4, Mitarbeiter!A3:D9, 4, FALSE).

Wenn Sie hinzufügen den Namen der Platte an den Anfang der Zelle range (Mitarbeiter!A3:D9), die SVERWEIS-Formel verwenden können, die Daten aus einem separaten Blatt in seiner Suche.

Mithilfe von Platzhaltern mit SVERWEIS

Unsere oben genannten Beispielen verwendet, genaue Suche-Taste Werte zum suchen von übereinstimmenden Daten. Wenn Sie nicht über eine exakte Suche-Wert key, Sie können auch Platzhalter verwenden, wie ein Fragezeichen oder ein Sternchen, das mit SVERWEIS.

Für dieses Beispiel verwenden wir den gleichen Satz von Daten aus unseren Beispielen oben, aber wenn wir uns bewegen, die “First Name” – Spalte, um die Spalte Ein, können wir mit einer partiellen ersten Namen und ein Sternchen als Platzhalter für die Suche die Nachnamen der Mitarbeiter.

Die SVERWEIS-Formel die Suche nach Familiennamen, die mit einer teilweisen erste name ist =SVERWEIS(B12, A3:D9, 2, FALSE); Ihre Suche nach Schlüssel-Wert geht in der Zelle B12.

Im Beispiel unten, “Chr*” in Zelle B12 entspricht den Beinamen “Geek” in der Beispiel-lookup-Tabelle.

Die Suche nach der Nächsten Übereinstimmung mit SVERWEIS

Sie können die letzten argument einer SVERWEIS-Formel zu suchen, entweder eine genaue oder am nächsten match zu Ihrer Suche nach Schlüssel-Wert. In unseren bisherigen Beispielen haben, suchten wir nach einer exakten übereinstimmung, so dass wir diesen Wert auf FALSE setzen.

Wenn Sie möchten, finden Sie den nächsten match auf einen Wert, ändern SVERWEIS das Letzte argument auf TRUE. Als dieses argument gibt an, ob eine Reihe sortiert ist oder nicht, stellen Sie sicher, dass Ihre such-Spalte, sortiert von A-Z, oder es wird nicht korrekt funktionieren.

In unserer Tabelle haben wir eine Liste von Elementen zu kaufen (A3 B9), zusammen mit Element-Namen und die Preise. Sie sind sortiert nach Preis vom niedrigsten zum höchsten. Unser Gesamt-budget zu verbringen, auf ein einzelnes Element ist $17 (Zelle D4) ein. Wir verwendeten eine SVERWEIS Formel zu finden, die meisten erschwinglichen Punkt auf der Liste.

Die entsprechende SVERWEIS-Formel für dieses Beispiel =SVERWEIS(D4, A4:B9; 2, WAHR). Da diese SVERWEIS-Formel ist der Satz zu finden, der die nächste übereinstimmung niedriger als der Wert selbst, es kann nur suchen Produkte billiger als die eingestellte budget von $17.

In diesem Beispiel, das billigste Element unter $17 ist die Tasche, die kostet $15, und das ist das Element der SVERWEIS-Formel als Ergebnis zurückgegeben in D5.

LESEN SIE WEITER

  • › 10 Möglichkeiten, um Personalisieren Ihre Slack-Konto
  • › Wie Sie Ihre Disney – + – Account Immer Gehackt
  • › Wie zum Download von Apple TV+ Shows auf dem iPhone, iPad und Mac
  • › How to Block Websites in Google Chrome
  • “So Verwenden Sie die OneDrive “Persönlichen Vault” Sichern Sie Ihre Dateien